Credential Provider

This topic describes Credential Provider system requirements.

CyberArk may choose not to provide maintenance and support services for the Secrets Manager Credential Providers solution in relation to any of the platforms and systems listed below that have reached their formal End-of-Life date, as published by their respective vendors from time to time. For more details, contact your CyberArk support representative.

Supported platforms for Credential Provider v14.0

Platform

Supported versions

AIX

  • AIX 7.2 TL5

  • AIX 7.3 TL1

Linux
  • RHEL-Intel:

    • 7.x

    • 8.x (64-bit)

    • 9.x (64-bit)

  • Oracle Linux:

    • 7 (64-bit)

    • 8 (64-bit)

    • 9 (64-bit)

  • CentOS Intel

    • 7 (64-bit)

  • CentOS Stream

    • 8

    • 9

  • Ubuntu 20 LTS, 22 LTS

Windows

  • Windows Server 2022

  • Windows Server 2019

  • Windows Server 2016

For developer endpoints:

  • Windows 11

  • Windows 10

This section contains documentation for the latest releases of the Credential Provider, including the latest releases of all Application Password SDKs. The Credential Provider is supported on different platforms, as described in the table above, and the information in this document is relevant to the most recent released version for each platform.

 
  • We recommend that you use the same version of the Credential Provider and the Application Password SDK.

  • Credential Providers supports IPv4 and IPv6.

Credential Provider Compatibility

This section lists the supported versions of CyberArk products that Credential Providers v14.0 is compatible with.

  • Credential Providers is compatible with the Digital Vault versions listed in this table as long as CyberArk supports the Digital Vault versions. For more information about the supported Digital Vault versions, see CyberArk's End-of-Life Policy.

  • For details about the Privilege Cloud integration with Secrets Manager Credential Provider, see Secrets Manager Credential Providers integration in the Privilege Cloud online help.

Credential Provider version

Works with

Supports

14.0

  • Digital Vault version 12.2 and later
  • Privilege Cloud

Application Password SDKs v12.1 and later