Application Password SDKs

The Application Password SDK is supported on a machine where the Credential Provider is installed. It is supported in the following application environments:

 

We recommend that you use the same version of the Credential Provider and the Application Password SDK.

SDK

Platform

Notes

C/C++

AIX

32-bit and 64-bit modules

Solaris

64-bit modules

Linux

32-bit and 64-bit modules

Windows

32-bit and 64-bit modules

Java (v1.7.x and later)

AIX

 

Solaris

Linux

Windows

CLI (Command Line Interface)

AIX

 

Solaris

Linux

Windows

.NET Framework (v4.5.2 and later)

Windows

 

.NET Standard (v2.0)

Windows

32-bit and 64-bit modules

Linux RHEL, SUSE (versions that support .NET Standard v2.0 and later)

64-bit modules

Ubuntu (versions that support .NET Standard v2.0 and later)

This section contains documentation for the latest release of all Application Password SDKs. The Credential Provider is supported on different platforms, as described in the table above, while the information in this document is relevant to the most recent released version for each platform. For information about the latest Credential Provider version, refer to the Credential Provider system requirements.

For information about upgrading from an existing PVToolkit implementation to the Credential Provider, contact your CyberArk support representative.

Application Password SDK Compatibility

The Application Password SDK supports the same version of Credential Provider and later versions.